Advisory Details

April 3rd, 2014

Novell ZENworks Configuration Management PreBoot Service Information Disclosure Vulnerability

ZDI-14-055
ZDI-CAN-1595

CVE ID CVE-2013-3706
CVSS SCORE 8.5, (AV:N/AC:L/Au:N/C:C/I:P/A:N)
AFFECTED VENDORS Novell
AFFECTED PRODUCTS ZENworks Configuration Manager
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Novell ZENworks Configuration Manager. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the Preboot Service (novell-pbserv.exe) which listens for incoming connections on TCP port 998. The service supports an opcode that allows for files to be downloaded through the use of directory traversal. By abusing this behavior an attacker can disclose administrative credentials and possibly leverage this situation to achieve remote code execution.

ADDITIONAL DETAILS Novell has issued an update to correct this vulnerability. More details can be found at:
http://www.novell.com/support/kb/doc.php?id=7014663
DISCLOSURE TIMELINE
  • 2013-01-20 - Vulnerability reported to vendor
  • 2014-04-03 - Coordinated public release of advisory
CREDIT Mak Kolybabi
BACK TO ADVISORIES