Advisory Details

May 2nd, 2014

InduSoft Web Studio Directory Traversal Remote Code Execution Vulnerability

ZDI-14-118
ZDI-CAN-2108

CVE ID CVE-2014-0780
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Indusoft
AFFECTED PRODUCTS WebStudio
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Indusoft Web Studio. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the ability to browse outside of the web root via directory traversal. A remote attacker can abuse this to download sensitive files and execute remote code under the context of the user.

ADDITIONAL DETAILS Indusoft has issued an update to correct this vulnerability. More details can be found at:
http://ics-cert.us-cert.gov/advisories/ICSA-14-107-02
DISCLOSURE TIMELINE
  • 2014-01-30 - Vulnerability reported to vendor
  • 2014-05-02 - Coordinated public release of advisory
CREDIT John Leitch
BACK TO ADVISORIES