Advisory Details

May 2nd, 2014

(Pwn2Own\Pwn4Fun) Apple OS X Graphics Driver Memory Corruption Remote Code Execution Vulnerability

ZDI-14-121
ZDI-CAN-2208

CVE ID CVE-2014-1318
CVSS SCORE 6.9, (AV:L/AC:M/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Apple
AFFECTED PRODUCTS OS X
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Apple OS X. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the Intel graphics driver. The issue lies in the failure to properly validate a pointer. An attacker can leverage this vulnerability to execute code within the context of the kernel.

ADDITIONAL DETAILS Apple has issued an update to correct this vulnerability. More details can be found at:
http://support.apple.com/kb/HT6207
DISCLOSURE TIMELINE
  • 2014-03-13 - Vulnerability reported to vendor
  • 2014-05-02 - Coordinated public release of advisory
CREDIT Ian Beer of Google Project Zero
BACK TO ADVISORIES