Advisory Details

June 13th, 2014

AlienVault OSSIM av-centerd Util.pm set_file Arbitrary File Write Remote Code Execution Vulnerability

ZDI-14-205
ZDI-CAN-2293

CVE ID CVE-2014-4151
CVSS SCORE 10.0, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS AlienVault
AFFECTED PRODUCTS OSSIM
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of AlienVault OSSIM. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the av-centerd SOAP service. The issue lies in the handling of set_file requests allowing for an arbitrary file write with attacker controlled data. An attacker could leverage this vulnerability to execute code with root privileges.

ADDITIONAL DETAILS AlienVault has issued an update to correct this vulnerability. More details can be found at:
http://forums.alienvault.com/discussion/2806
DISCLOSURE TIMELINE
  • 2014-04-18 - Vulnerability reported to vendor
  • 2014-06-13 - Coordinated public release of advisory
CREDIT HP Zero Day Initiative
BACK TO ADVISORIES