Advisory Details

October 1st, 2014

Hewlett-Packard Network Node Manager ovopi.dll Option -T Remote Code Execution Vulnerability

ZDI-14-341
ZDI-CAN-2178

CVE ID CVE-2014-2624
CVSS SCORE 10, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Hewlett-Packard
AFFECTED PRODUCTS Network Node Manager
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 13681. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Hewlett-Packard Network Node Manager. Authentication is not required to exploit this vulnerability.

The specific flaw exists within ovopi.dll which listens by default on a UDP port 696. When parsing option -T, the process blindly copies user supplied data into a fixed-length buffer allowing for an arbitrary write to occur. A remote attacker can abuse this to execute remote code under the context of the SYSTEM user.

VENDOR RESPONSE Hewlett-Packard has issued an update to correct this vulnerability. More details can be found at:
https://h20565.www2.hp.com/portal/site/hpsc/template.PAGE/public/kb/docDisplay/?spf_p.tpst=kbDocDisplay&spf_p.prp_kbDocDisplay=wsrp-navigationalState%3DdocId%253Demr_na-c04378450-2%257CdocLocale%253D%257CcalledBy%253D&
DISCLOSURE TIMELINE
  • 2014-03-07 - Vulnerability reported to vendor
  • 2014-10-01 - Coordinated public release of advisory
CREDIT sztivi
BACK TO ADVISORIES