Advisory Details

April 3rd, 2015

ManageEngine Desktop Central MSP AndroidCheckInServlet UDID Remote Code Execution Vulnerability

ZDI-15-114
ZDI-CAN-2448

CVE ID
CVSS SCORE 10, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS ManageEngine
AFFECTED PRODUCTS Destkop Central MSP
TIPPINGPOINT™ IPS CUSTOMER PROTECTION TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 16594. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of ManageEngine Desktop Central MSP. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the AndroidCheckInServlet servlet. The issue lies in the failure to sanitize JSON data before processing it. An attacker can leverage this vulnerability to execute code under the context of SYSTEM.

VENDOR RESPONSE ManageEngine has issued an update to correct this vulnerability. More details can be found at:
https://www.manageengine.com/products/desktop-central/hotfix-readme.html
DISCLOSURE TIMELINE
  • 2014-08-18 - Vulnerability reported to vendor
  • 2015-04-03 - Coordinated public release of advisory
CREDIT Andrea Micalizzi (rgod)
BACK TO ADVISORIES