Advisory Details

April 15th, 2016

Hewlett Packard Enterprise Vertica validateAdminConfig Remote Command Injection Vulnerability

ZDI-16-244
ZDI-CAN-3417

CVE ID CVE-2016-2002
CVSS SCORE 10, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Hewlett Packard Enterprise
AFFECTED PRODUCTS Vertica
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Hewlett Packard Enterprise Vertica. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the validateAdminConfig handler. By providing an mcPort parameter containing command injection, an attacker can execute arbitrary commands as root.

ADDITIONAL DETAILS Hewlett Packard Enterprise has issued an update to correct this vulnerability. More details can be found at:
https://h20564.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay/?docId=emr_na-c05085303
DISCLOSURE TIMELINE
  • 2015-12-01 - Vulnerability reported to vendor
  • 2016-04-15 - Coordinated public release of advisory
CREDIT agix
BACK TO ADVISORIES