Advisory Details

May 11th, 2016

Panasonic FPWIN Pro OPNISAMX Heap Buffer Overflow Remote Code Execution Vulnerability

ZDI-16-330
ZDI-CAN-3446

CVE ID CVE-2016-4499
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Panasonic
AFFECTED PRODUCTS FPWIN Pro
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 22806. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Panasonic FPWIN Pro. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within parsing of project files. A specially-crafted project file can cause a heap buffer overrun in a memcpy call. An attacker can leverage this vulnerability to execute arbitrary code in the context of the current process.

ADDITIONAL DETAILS Panasonic has issued an update to correct this vulnerability. More details can be found at:
https://ics-cert.us-cert.gov/advisories/ICSA-16-131-01
DISCLOSURE TIMELINE
  • 2016-01-19 - Vulnerability reported to vendor
  • 2016-05-11 - Coordinated public release of advisory
CREDIT Steven Seeley of Source Incite
BACK TO ADVISORIES