Advisory Details

May 20th, 2016

Trend Micro InterScan Web Security Virtual Appliance wmi_domain_controllers Remote Code Execution Vulnerability

ZDI-16-350
ZDI-CAN-3514

CVE ID
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Trend Micro
AFFECTED PRODUCTS InterScan Web Security
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 23798. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Trend Micro InterScan Web Security. Authentication is not required to exploit this vulnerability.

The specific flaw exists within processing of the /rest/wmi_domain_controllers requests. Multiple parameters required for the request are subject to command injection. An attacker can leverage this vulnerability to execute arbitrary commands in the context of the process.

VENDOR RESPONSE Trend Micro has issued an update to correct this vulnerability. More details can be found at:
http://esupport.trendmicro.com/solution/en-US/1114185.aspx
DISCLOSURE TIMELINE
  • 2016-01-22 - Vulnerability reported to vendor
  • 2016-05-20 - Coordinated public release of advisory
CREDIT Brian Gorenc - HPE Zero Day Initiative
BACK TO ADVISORIES