Advisory Details

June 3rd, 2016

Eclipse Jetty Protected Resource Bypass Vulnerability

ZDI-16-362
ZDI-CAN-3707

CVE ID CVE-2016-4800
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Eclipse
AFFECTED PRODUCTS Jetty
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 24494. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Eclipse Jetty. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the way the ContextHandler class restricts access to protected resources. By issuing a crafted request, an attacker can gain access to the code of a web application deployed in Jetty. An attacker can use this knowledge in further attacks against the web application. Additionally, if the web application allows file uploads, it may be possible for an attacker to modify the code of the web application, achieving a direct path to executing arbitrary code under the context of the server process.

ADDITIONAL DETAILS Eclipse has issued an update to correct this vulnerability. More details can be found at:
http://www.ocert.org/advisories/ocert-2016-001.html
DISCLOSURE TIMELINE
  • 2016-05-03 - Vulnerability reported to vendor
  • 2016-06-03 - Coordinated public release of advisory
CREDIT Simon Zuckerbraun - Trend Micro Zero Day Initiative
BACK TO ADVISORIES