Advisory Details

June 3rd, 2016

Hewlett Packard Enterprise LoadRunner Virtual Table Server import_csv Denial of Service Vulnerability

ZDI-16-364
ZDI-CAN-3555

CVE ID CVE-2016-4360
CVSS SCORE 8.5, (AV:N/AC:L/Au:N/C:N/I:P/A:C)
AFFECTED VENDORS Hewlett Packard Enterprise
AFFECTED PRODUCTS LoadRunner
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 24361. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to delete arbitrary files on vulnerable installations of Hewlett Packard Enterprise LoadRunner. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the import_csv functionality. The issue lies in the failure to restrict file paths sent to an unlink call which allows for the deletion of arbitrary files as SYSTEM. A remote attacker can leverage this vulnerability to cause a denial-of-service condition.

ADDITIONAL DETAILS Hewlett Packard Enterprise has issued an update to correct this vulnerability. More details can be found at:
https://h20566.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-c05157423
DISCLOSURE TIMELINE
  • 2016-02-12 - Vulnerability reported to vendor
  • 2016-06-03 - Coordinated public release of advisory
CREDIT Tenable Network Security
BACK TO ADVISORIES