Advisory Details

January 24th, 2017

Oracle Java AtomicReferenceFieldUpdater Type Confusion Remote Code Execution Vulnerability

ZDI-17-056
ZDI-CAN-3834

CVE ID CVE-2017-3272
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Oracle
AFFECTED PRODUCTS Java
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Oracle Java. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the AtomicReferenceFieldUpdater class. Due to insufficient type checking involving this class, it is possible for untrusted code to gain access to privileged methods and properties. An attacker can leverage this vulnerability to execute code under the context of the process.

ADDITIONAL DETAILS Oracle has issued an update to correct this vulnerability. More details can be found at:
http://www.oracle.com/technetwork/security-advisory/cpujan2017-2881727.html
DISCLOSURE TIMELINE
  • 2016-08-30 - Vulnerability reported to vendor
  • 2017-01-24 - Coordinated public release of advisory
CREDIT XOR19
BACK TO ADVISORIES