Advisory Details

September 7th, 2017

Foxit Reader XFA gotoURL Command Injection Remote Code Execution Vulnerability

ZDI-17-718
ZDI-CAN-5030

CVE ID CVE-2017-10953
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Foxit
AFFECTED PRODUCTS Reader
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the gotoURL method. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code under the context of the current process.

VENDOR RESPONSE Foxit has issued an update to correct this vulnerability. More details can be found at:
https://www.foxitsoftware.com/support/security-bulletins.php
DISCLOSURE TIMELINE
  • 2017-08-08 - Vulnerability reported to vendor
  • 2017-09-07 - Coordinated public release of advisory
CREDIT Steven Seeley (mr_me) of Offensive Security
BACK TO ADVISORIES