Advisory Details

December 13th, 2017

NetGain Systems Enterprise Manager tools.exec_jsp command Command Injection Remote Code Execution Vulnerability

ZDI-17-967
ZDI-CAN-5193

CVE ID CVE-2017-16602
CVSS SCORE 9, (AV:N/AC:L/Au:S/C:C/I:C/A:C)
AFFECTED VENDORS NetGain Systems
AFFECTED PRODUCTS Enterprise Manager
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 29825. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of NetGain Systems Enterprise Manager. Although authentication is required to exploit this vulnerability, the existing authentication mechanism can be bypassed.

The specific flaw exists within the org.apache.jsp.u.jsp.tools.exec_jsp servlet, which listens on TCP port 8081 by default. When parsing the command parameter, the process does not properly validate a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code under the context of Administrator.

ADDITIONAL DETAILS


Fixed for NetGain Enterprise Manager - fixed version: v7.2.766 and above


DISCLOSURE TIMELINE
  • 2017-09-08 - Vulnerability reported to vendor
  • 2017-12-13 - Coordinated public release of advisory
CREDIT rgod
BACK TO ADVISORIES