Advisory Details

December 15th, 2017

Quest NetVault Backup Server Process Manager Service NVBUEventHistory Get Method SQL Injection Remote Code Execution Vulnerability

ZDI-17-974
ZDI-CAN-4223

CVE ID CVE-2017-17412
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Quest
AFFECTED PRODUCTS NetVault Backup
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Quest NetVault Backup. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the handling of GET method requests. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to execute arbitrary code in the context of the underlying database.

ADDITIONAL DETAILS


Fixed in NVBU 11.4.5


DISCLOSURE TIMELINE
  • 2017-12-06 - Vulnerability reported to vendor
  • 2017-12-15 - Coordinated public release of advisory
CREDIT rgod
BACK TO ADVISORIES