Advisory Details

January 2nd, 2018

Quest NetVault Backup Server Process Manager Service NVBUJobDefinitions Get Method SQL Injection Remote Code Execution Vulnerability

ZDI-17-994
ZDI-CAN-4316

CVE ID CVE-2017-17658
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Quest
AFFECTED PRODUCTS NetVault Backup
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 28751. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Quest NetVault Backup. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the handling of NVBUJobDefinitions Get method requests. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to execute code in the context of the underlying database.

ADDITIONAL DETAILS


fixed in 11.4.5


DISCLOSURE TIMELINE
  • 2017-12-06 - Vulnerability reported to vendor
  • 2018-01-02 - Coordinated public release of advisory
CREDIT rgod
BACK TO ADVISORIES