Advisory Details

January 5th, 2018

Advantech WebAccess gChkUser ChkAdminViewUsrPwd SQL Injection Authentication Bypass Vulnerability

ZDI-18-064
ZDI-CAN-5398

CVE ID CVE-2017-16716
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Advantech
AFFECTED PRODUCTS WebAccess
VULNERABILITY DETAILS


This vulnerability allows remote attackers to bypass authentication on vulnerable installations of Advantech WebAccess.

The specific flaw exists within the ChkAdminViewUsrPwd method of the gChkUser.asp servlet, called by the gmap.asp servlet. When parsing the user and proj parameters, the process does not properly validate user-supplied strings before using them to construct SQL queries. An attacker can leverage this in conjunction with other vulnerabilities to execute code in the context of the database.

VENDOR RESPONSE Advantech has issued an update to correct this vulnerability. More details can be found at:
https://ics-cert.us-cert.gov/advisories/ICSA-18-004-02
DISCLOSURE TIMELINE
  • 2017-12-01 - Vulnerability reported to vendor
  • 2018-01-05 - Coordinated public release of advisory
CREDIT rgod
BACK TO ADVISORIES