Advisory Details

April 20th, 2018

Foxit Reader Annotation author Use-After-Free Remote Code Execution Vulnerability

ZDI-18-346
ZDI-CAN-5435

CVE ID CVE-2018-9962
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Foxit
AFFECTED PRODUCTS Reader
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of Annotation's author attribute. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code under the context of the current process.

ADDITIONAL DETAILS Foxit has issued an update to correct this vulnerability. More details can be found at:
https://www.foxitsoftware.com/support/security-bulletins.php
DISCLOSURE TIMELINE
  • 2018-01-31 - Vulnerability reported to vendor
  • 2018-04-20 - Coordinated public release of advisory
  • 2018-04-20 - Advisory Updated
CREDIT Steven Seeley (mr_me) of Source Incite
BACK TO ADVISORIES