Advisory Details

June 6th, 2018

GE MDS PulseNET FileServlet Directory Traversal Information Disclosure Vulnerability

ZDI-18-546
ZDI-CAN-5520

CVE ID CVE-2018-10615
CVSS SCORE 4, (AV:N/AC:L/Au:S/C:P/I:N/A:N)
AFFECTED VENDORS GE
AFFECTED PRODUCTS MDS PulseNET
VULNERABILITY DETAILS


This vulnerability allows remote attackers to disclose sensitive information on vulnerable installations of GE MDS PulseNET. Although authentication is required to exploit this vulnerability, the existing authentication mechanism can be bypassed.

The specific flaw exists within the FileServlet servlet. When parsing the name parameter, the process does not properly validate a user-supplied path prior to using it in file operations. An attacker can leverage this vulnerability to disclose information under the context of the current service.

ADDITIONAL DETAILS GE has issued an update to correct this vulnerability. More details can be found at:
https://ics-cert.us-cert.gov/advisories/ICSA-18-151-02
DISCLOSURE TIMELINE
  • 2018-01-10 - Vulnerability reported to vendor
  • 2018-06-06 - Coordinated public release of advisory
  • 2018-06-06 - Advisory Updated
CREDIT rgod
BACK TO ADVISORIES