Advisory Details

July 26th, 2018

(0Day) Wecon LeviStudioU screenhelper BgOnOffBitAddr Stack-based Buffer Overflow Remote Code Execution Vulnerability

ZDI-18-794
ZDI-CAN-5798

CVE ID CVE-2018-10602
CVSS SCORE 9.3, (AV:N/AC:M/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Wecon
AFFECTED PRODUCTS LeviStudioU
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Wecon LeviStudioU. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the handling of UMP files. When parsing the BgOnOffBitAddr element, the process does not properly validate the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code under the context of Administrator.

ADDITIONAL DETAILS Wecon has issued an update to correct this vulnerability. More details can be found at:
https://ics-cert.us-cert.gov/advisories/ICSA-18-212-03


This vulnerability is being disclosed publicly without a patch in accordance with the ZDI 120 day deadline.

03/07/18 - ZDI disclosed the report to ICS-CERT
03/12/18 - ICS-CERT assigned ICS‑VU‑031741 and notified ZDI
07/06/18 - ZDI inquired the status of ICS‑VU‑031741
07/09/18 - ICS-CERT replied that they would advise the vendor
07/19/18 - ZDI advised ICS-CERT of the intended 0-day date: 07/26/2018

-- Mitigation:
Given the nature of the vulnerability the only salient mitigation strategy is to restrict interaction with the application to trusted files.


DISCLOSURE TIMELINE
  • 2018-03-07 - Vulnerability reported to vendor
  • 2018-07-26 - Coordinated public release of advisory
  • 2018-08-02 - Advisory Updated
CREDIT Ghirmay Desta
BACK TO ADVISORIES