Advisory Details

August 14th, 2018

Crestron Multiple Products CTP Console ADDUSER Command Injection Remote Code Execution Vulnerability

ZDI-18-925
ZDI-CAN-6166

CVE ID CVE-2018-11228
CVSS SCORE 8.5, (AV:N/AC:M/Au:S/C:C/I:C/A:C)
AFFECTED VENDORS Crestron
AFFECTED PRODUCTS TSW-760
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Crestron's Android-based products. Authentication is required to exploit this vulnerability.

The specific flaw exists within the ADDUSER command of the CTP console. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker could leverage this vulnerability to execute code with root privileges.

ADDITIONAL DETAILS Crestron has issued an update to correct this vulnerability. More details can be found at:
https://ics-cert.us-cert.gov/advisories/ICSA-18-221-01
DISCLOSURE TIMELINE
  • 2018-05-08 - Vulnerability reported to vendor
  • 2018-08-14 - Coordinated public release of advisory
  • 2018-08-14 - Advisory Updated
CREDIT Ricky "HeadlessZeke" Lawshae
BACK TO ADVISORIES