Advisory Details

January 29th, 2020

Hewlett Packard Enterprise Intelligent Management Center UrlAccessController Authentication Bypass Vulnerability

ZDI-19-1038
ZDI-CAN-8943

CVE ID
CVSS SCORE 9.8, (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Hewlett Packard Enterprise
AFFECTED PRODUCTS Intelligent Management Center
VULNERABILITY DETAILS

This vulnerability allows remote attackers to bypass authentication on affected installations of Hewlett Packard Enterprise Intelligent Management Center.

The specific flaw exists within the UrlAccessController servlet. The issue results from the lack of proper filtering of URLs. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of SYSTEM.

ADDITIONAL DETAILS Hewlett Packard Enterprise has issued an update to correct this vulnerability. More details can be found at:
https://support.hpe.com/hpsc/doc/public/display?docId=a00093539en_us
DISCLOSURE TIMELINE
  • 2019-08-09 - Vulnerability reported to vendor
  • 2020-01-29 - Coordinated public release of advisory
CREDIT Steven Seeley (mr_me) of Source Incite
BACK TO ADVISORIES