Advisory Details

June 21st, 2019

Apache Tomcat reserveWindowSize Denial-Of-Service Vulnerability

ZDI-19-582
ZDI-CAN-8630

CVE ID CVE-2019-10072
CVSS SCORE 5.3, (AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)
AFFECTED VENDORS Apache
AFFECTED PRODUCTS Tomcat
VULNERABILITY DETAILS

This vulnerability allows remote attackers to create a denial-of-service condition on vulnerable installations of Apache Tomcat. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the handling of HTTP2 requests. A crafted HTTP2 request can create a deadlock on a worker thread. An attacker can leverage this vulnerability to create a denial-of-service condition on the system.

ADDITIONAL DETAILS Apache has issued an update to correct this vulnerability. More details can be found at:
http://tomcat.apache.org/security-9.html
DISCLOSURE TIMELINE
  • 2019-04-26 - Vulnerability reported to vendor
  • 2019-06-21 - Coordinated public release of advisory
CREDIT John Simpson of Trend Micro Security Research
BACK TO ADVISORIES