Advisory Details

July 5th, 2019

Foxit Reader AcroForm deleteItemAt Use-After-Free Remote Code Execution Vulnerability

ZDI-19-629
ZDI-CAN-8295

CVE ID CVE-2019-6774
CVSS SCORE 7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Foxit
AFFECTED PRODUCTS Reader
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Foxit Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the deleteItemAt method when processing AcroForms. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS Foxit has issued an update to correct this vulnerability. More details can be found at:
https://www.foxitsoftware.com/support/security-bulletins.php
DISCLOSURE TIMELINE
  • 2019-04-03 - Vulnerability reported to vendor
  • 2019-07-05 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES