Advisory Details

November 1st, 2019

Advantech WISE-PaaS/RMM NodeRed Server Missing Authentication Remote Code Execution Vulnerability

ZDI-19-960
ZDI-CAN-8891

CVE ID CVE-2019-13547
CVSS SCORE 9.8, (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Advantech
AFFECTED PRODUCTS WISE-PaaS/RMM
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Advantech WISE-PaaS/RMM. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the NodeRed Server, which listens on TCP port 1880 by default. The issue results from the lack of authentication prior to allowing alterations to the system configuration. An attacker can leverage this vulnerability to execute code in the context of SYSTEM.

ADDITIONAL DETAILS Advantech has issued an update to correct this vulnerability. More details can be found at:
https://www.us-cert.gov/ics/advisories/icsa-19-304-01
DISCLOSURE TIMELINE
  • 2019-07-11 - Vulnerability reported to vendor
  • 2019-11-01 - Coordinated public release of advisory
CREDIT rgod of 9sg
BACK TO ADVISORIES