Advisory Details

October 22nd, 2020

Oracle E-Business Suite ozfVendorLov SQL Injection Information Disclosure Vulnerability

ZDI-20-1283
ZDI-CAN-11687

CVE ID CVE-2020-14876
CVSS SCORE 7.5, (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N)
AFFECTED VENDORS Oracle
AFFECTED PRODUCTS E-Business Suite
VULNERABILITY DETAILS

This vulnerability allows remote attackers to escalate privileges on affected installations of Oracle E-Business Suite. Authentication is not required to exploit this vulnerability.

The specific flaw exists within ozfVendorLov.jsp. The issue results from the lack of proper validation of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to disclose stored credentials, leading to further compromise.

ADDITIONAL DETAILS Oracle has issued an update to correct this vulnerability. More details can be found at:
https://www.oracle.com/security-alerts/cpuoct2020.html
DISCLOSURE TIMELINE
  • 2020-10-14 - Vulnerability reported to vendor
  • 2020-10-22 - Coordinated public release of advisory
CREDIT Tuan Anh Nguyen of Viettel Cyber Security
BACK TO ADVISORIES