Advisory Details

December 15th, 2020

(0Day) Linux Kernel eBPF Improper Input Validation Privilege Escalation Vulnerability

ZDI-20-1440
ZDI-CAN-10905

CVE ID
CVSS SCORE 8.8, (AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H)
AFFECTED VENDORS Linux
AFFECTED PRODUCTS Kernel
VULNERABILITY DETAILS

This vulnerability allows local attackers to escalate privileges on affected installations of Linux Kernel. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.

The specific flaw exists within the handling of eBPF programs. The issue results from the lack of proper validation of user-supplied eBPF programs prior to executing them. An attacker can leverage this vulnerability to escalate privileges and execute code in the context of the kernel.

ADDITIONAL DETAILS

This vulnerability is being disclosed publicly without a patch in accordance with the ZDI 120 day deadline.

05/20/20 - ZDI reported the vulnerability to the vendor
05/26/20 - The vendor confirmed receipt of the report
09/09/20 - ZDI requested an update from the vendor
10/05/20 - ZDI requested an update from the vendor
10/15/20 - ZDI notified the vendor of the intention to publish the report as 0-day advisory on 10/20/2020

-- Mitigation:
Given the nature of the vulnerability the only salient mitigation strategy is to restrict interaction with the application.


DISCLOSURE TIMELINE
  • 2020-05-20 - Vulnerability reported to vendor
  • 2020-12-15 - Coordinated public release of advisory
CREDIT Ryota Shiga(@Ga_ryo_) of Flatt Security
BACK TO ADVISORIES