Advisory Details

December 18th, 2020

Hewlett Packard Enterprise Systems Insight Manager AMF Deserialization of Untrusted Data Remote Code Execution Vulnerability

ZDI-20-1449
ZDI-CAN-11847

CVE ID CVE-2020-7200
CVSS SCORE 9.8, (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Hewlett Packard Enterprise
AFFECTED PRODUCTS Systems Insight Manager
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Hewlett Packard Enterprise Systems Insight Manager. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the handling of the AMF protocol. Crafted data in an AMF protocol message can trigger the deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of SYSTEM.

ADDITIONAL DETAILS Hewlett Packard Enterprise has issued an update to correct this vulnerability. More details can be found at:
https://support.hpe.com/hpesc/public/docDisplay?docLocale=en_US&docId=hpesbgn04068en_us
DISCLOSURE TIMELINE
  • 2020-10-30 - Vulnerability reported to vendor
  • 2020-12-18 - Coordinated public release of advisory
CREDIT Harrison Neal
BACK TO ADVISORIES