Advisory Details

March 5th, 2020

IBM Spectrum Protect Plus hfpackage Command Injection Remote Code Execution Vulnerability

ZDI-20-272
ZDI-CAN-9954

CVE ID CVE-2020-4212
CVSS SCORE 9.8, (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS IBM
AFFECTED PRODUCTS Spectrum Protect Plus
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of IBM Spectrum Protect Plus. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the Administrative Console Framework service. When parsing the hfpackage parameter, the process does not properly validate a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root.

ADDITIONAL DETAILS IBM has issued an update to correct this vulnerability. More details can be found at:
https://www.ibm.com/support/pages/node/3178863
DISCLOSURE TIMELINE
  • 2019-12-12 - Vulnerability reported to vendor
  • 2020-03-05 - Coordinated public release of advisory
CREDIT KPC
BACK TO ADVISORIES