Advisory Details

May 12th, 2020

(Pwn2Own) Adobe Acrobat Reader DC Field Use-After-Free Remote Code Execution Vulnerability

ZDI-20-651
ZDI-CAN-10784

CVE ID CVE-2020-9606
CVSS SCORE 7.3, (AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)
AFFECTED VENDORS Adobe
AFFECTED PRODUCTS Acrobat Reader DC
VULNERABILITY DETAILS

This vulnerability allows local attackers to escalate privileges on affected installations of Adobe Reader. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.

The specific flaw exists within the handling of Field objects. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS Adobe has issued an update to correct this vulnerability. More details can be found at:
https://helpx.adobe.com/security/products/acrobat/apsb20-24.html
DISCLOSURE TIMELINE
  • 2020-03-25 - Vulnerability reported to vendor
  • 2020-05-12 - Coordinated public release of advisory
  • 2020-08-18 - Advisory Updated
CREDIT Fluoroacetate
BACK TO ADVISORIES