Advisory Details

June 30th, 2020

VMware Workstation EHCI Heap-based Buffer Overflow Privilege Escalation Vulnerability

ZDI-20-784
ZDI-CAN-10694

CVE ID CVE-2020-3967
CVSS SCORE 7.5, (AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H)
AFFECTED VENDORS VMware
AFFECTED PRODUCTS Workstation
VULNERABILITY DETAILS

This vulnerability allows local attackers to escalate privileges on affected installations of VMware Workstation. An attacker must first obtain the ability to execute high-privileged code on the target guest system in order to exploit this vulnerability.

The specific flaw exists within the EHCI component. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a heap-based buffer. An attacker can leverage this vulnerability to escalate privileges and execute code in the context of the hypervisor.

ADDITIONAL DETAILS VMware has issued an update to correct this vulnerability. More details can be found at:
https://www.vmware.com/security/advisories/VMSA-2020-0015.html
DISCLOSURE TIMELINE
  • 2020-03-15 - Vulnerability reported to vendor
  • 2020-06-30 - Coordinated public release of advisory
CREDIT Reno Robert
BACK TO ADVISORIES