Advisory Details

July 20th, 2020

Oracle VirtualBox Guest Additions Unnecessary Privileges Local Privilege Escalation Vulnerability

ZDI-20-886
ZDI-CAN-10762

CVE ID CVE-2020-14628
CVSS SCORE 8.2, (AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H)
AFFECTED VENDORS Oracle
AFFECTED PRODUCTS VirtualBox
VULNERABILITY DETAILS

This vulnerability allows local attackers to escalate privileges on affected installations of Oracle VirtualBox. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.

The specific flaw exists within the Guest Additions toolset. The issue results from the use of unnecessary privileges when performing service operations. An attacker can leverage this vulnerability to escalate privileges and execute code in the context of SYSTEM.

ADDITIONAL DETAILS Oracle has issued an update to correct this vulnerability. More details can be found at:
https://www.oracle.com/security-alerts/cpujul2020.html
DISCLOSURE TIMELINE
  • 2020-04-14 - Vulnerability reported to vendor
  • 2020-07-20 - Coordinated public release of advisory
CREDIT Conor McErlane
BACK TO ADVISORIES