Advisory Details

August 11th, 2020

Canonical Ubuntu Virtualization Library Arbitrary File Write Privilege Escalation Vulnerability

ZDI-20-981
ZDI-CAN-11561

CVE ID CVE-2020-15708
CVSS SCORE 7.8, (AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Canonical
AFFECTED PRODUCTS Ubuntu
VULNERABILITY DETAILS

This vulnerability allows local attackers to write arbitrary files on affected installations of Libvirt. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.

The specific flaw exists within the libvirt service. The issue results from improper access control when handling the vol-upload command, which allows an arbitrary file write with attacker controlled data. An attacker can leverage this vulnerability to escalate privileges and execute code in the context of root.

ADDITIONAL DETAILS Canonical has issued an update to correct this vulnerability. More details can be found at:
https://ubuntu.com/security/notices/USN-4452-1
DISCLOSURE TIMELINE
  • 2020-07-24 - Vulnerability reported to vendor
  • 2020-08-11 - Coordinated public release of advisory
CREDIT Trent Shea
BACK TO ADVISORIES