Advisory Details

July 13th, 2021

Apple macOS vImage PICT File Parsing Out-Of-Bounds Write Remote Code Execution Vulnerability

ZDI-21-793
ZDI-CAN-13627

CVE ID CVE-2021-30701
CVSS SCORE 7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Apple
AFFECTED PRODUCTS macOS
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Apple macOS. Interaction with the vImage library is required to exploit this vulnerability but attack vectors may vary depending on the implementation.

The specific flaw exists within the vImage framework. Crafted data in a PICT file can trigger a write past the end of an allocated data structure. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS Apple has issued an update to correct this vulnerability. More details can be found at:
https://support.apple.com/HT212529
DISCLOSURE TIMELINE
  • 2021-05-07 - Vulnerability reported to vendor
  • 2021-07-13 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES