Advisory Details

August 17th, 2021

(Pwn2Own) Zoom Client Marketplace Use of Incorrectly-Resolved Name or Reference Information Disclosure Vulnerability

ZDI-21-972
ZDI-CAN-13616

CVE ID
CVSS SCORE 5.3, (AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
AFFECTED VENDORS Zoom
AFFECTED PRODUCTS Client
VULNERABILITY DETAILS

This vulnerability allows remote attackers to disclose sensitive information on affected installations of Zoom Clients. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the processing of Zoom Marketplace URLs. The issue results from the lack of proper validation of a user-supplied path prior to using it to access Marketplace resources. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of the current user.

ADDITIONAL DETAILS Zoom has issued an update to correct this vulnerability. More details can be found at:
https://explore.zoom.us/en/trust/security/security-bulletin/
DISCLOSURE TIMELINE
  • 2021-04-07 - Vulnerability reported to vendor
  • 2021-08-17 - Coordinated public release of advisory
CREDIT Daan Keuper and Thijs Alkemade from Computest
BACK TO ADVISORIES