Advisory Details

July 15th, 2022

ABB Automation Builder Platform Link Following Local Privilege Escalation Vulnerability

ZDI-22-1013
ZDI-CAN-16277

CVE ID CVE-2022-31217
CVSS SCORE 7.8, (AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS ABB
AFFECTED PRODUCTS Automation Builder Platform
VULNERABILITY DETAILS

This vulnerability allows local attackers to escalate privileges on affected installations of ABB Automation Builder Platform. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.

The specific flaw exists within the Drive Composer installer. By creating a symbolic link, an attacker can abuse the installer to overwrite a file. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of SYSTEM.

ADDITIONAL DETAILS ABB has issued an update to correct this vulnerability. More details can be found at:
https://library.e.abb.com/public/0bc9ed3188ff43be94f2cbdc1751a72d/Vulnerabilities_in_Automation_Builder_and_Drive_Composer_and_Mint_WorkBench.pdf?x-sign=Dsvwu1eOxEWGDKECZJMzhUkv4wylDwof6PtNKvY8QFk+nBjFCRKlgeR096xY5FkJ
DISCLOSURE TIMELINE
  • 2022-01-26 - Vulnerability reported to vendor
  • 2022-07-15 - Coordinated public release of advisory
CREDIT Michael DePlante (@izobashi) of Trend Micro's Zero Day Initiative
BACK TO ADVISORIES