Advisory Details

August 3rd, 2022

ICONICS GENESIS64 GenBroker64 Out-Of-Bounds Read Information Disclosure Vulnerability

ZDI-22-1044
ZDI-CAN-17389

CVE ID CVE-2022-33319
CVSS SCORE 6.5, (AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H)
AFFECTED VENDORS ICONICS
AFFECTED PRODUCTS GENESIS64
VULNERABILITY DETAILS

This vulnerability allows remote attackers to disclose sensitive information on affected installations of ICONICS GENESIS64 GenBroker64. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the GenBroker64 service, which listens on TCP port 38080 by default. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated buffer. An attacker can leverage this vulnerability to disclose information in the context of the current process or to create a denial-of-service condition on the system.

ADDITIONAL DETAILS ICONICS has issued an update to correct this vulnerability. More details can be found at:
https://www.cisa.gov/uscert/ics/advisories/icsa-22-202-04
DISCLOSURE TIMELINE
  • 2022-05-25 - Vulnerability reported to vendor
  • 2022-08-03 - Coordinated public release of advisory
CREDIT Axel '0vercl0k' Souchet from https://doar-e.github.io/
BACK TO ADVISORIES