Advisory Details

September 29th, 2022

(0Day) GE CIMPLICITY CIM File Parsing Untrusted Pointer Dereference Remote Code Execution Vulnerability

ZDI-22-1322
ZDI-CAN-15574

CVE ID
CVSS SCORE 7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS GE
AFFECTED PRODUCTS CIMPLICITY
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of GE CIMPLICITY. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of CIM files. The issue results from the lack of proper validation of a user-supplied value prior to dereferencing it as a pointer. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS

03/02/22 – ZDI reported the vulnerability to ICS-CERT to coordinate with the vendor.

03/02/22 – The vendor acknowledged the vulnerability report.

05/20/22 – ICS-CERT asked for an update.

05/26/22 – The vendor stated that they are reviewing the case on 5/31/22.

05/31/22 – The vendor sent an update about the progress of the report.

07/19/22 – ICS-CERT asked for an update.

09/20/22 – ZDI informed the vendor that this case will be published as a zero-day advisory on 09/28/22.

-- Mitigation: Given the nature of the vulnerability, the only salient mitigation strategy is to restrict interaction with the application.


DISCLOSURE TIMELINE
  • 2022-03-02 - Vulnerability reported to vendor
  • 2022-09-29 - Coordinated public release of advisory
CREDIT kimiya
BACK TO ADVISORIES