Advisory Details

October 14th, 2022

Adobe Dimension GLB File Parsing Out-Of-Bounds Read Remote Code Execution Vulnerability

ZDI-22-1429
ZDI-CAN-18616

CVE ID CVE-2022-38441
CVSS SCORE 7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Adobe
AFFECTED PRODUCTS Dimension
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Adobe Dimension. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of GLB files. Crafted data in a GLB file can trigger a read past the end of an allocated buffer. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS Adobe has issued an update to correct this vulnerability. More details can be found at:
https://helpx.adobe.com/security/products/dimension/apsb22-57.html
DISCLOSURE TIMELINE
  • 2022-09-02 - Vulnerability reported to vendor
  • 2022-10-14 - Coordinated public release of advisory
CREDIT Mat Powell of Trend Micro Zero Day Initiative
BACK TO ADVISORIES