Advisory Details

October 21st, 2022

LibreOffice Exposed Dangerous Function Remote Code Execution Vulnerability

ZDI-22-1456
ZDI-CAN-17859

CVE ID CVE-2022-3140
CVSS SCORE 7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS LibreOffice
AFFECTED PRODUCTS LibreOffice
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of LibreOffice. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of document files. The issue results from an exposed dangerous function. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS LibreOffice has issued an update to correct this vulnerability. More details can be found at:
https://www.libreoffice.org/about-us/security/advisories/CVE-2022-3140
DISCLOSURE TIMELINE
  • 2022-08-24 - Vulnerability reported to vendor
  • 2022-10-21 - Coordinated public release of advisory
CREDIT TheSecurityDev
BACK TO ADVISORIES