Advisory Details

October 21st, 2022

GNU Gzip zgrep Argument Injection Remote Code Execution Vulnerability

ZDI-22-1458
ZDI-CAN-16588

CVE ID
CVSS SCORE 7.0, (AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS GNU
AFFECTED PRODUCTS Gzip
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of GNU Gzip. Interaction with this script is required to exploit this vulnerability but attack vectors may vary depending on the implementation.

The specific flaw exists within the handling of special characters. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system command. An attacker can leverage this vulnerability to execute code on the system.

ADDITIONAL DETAILS GNU has issued an update to correct this vulnerability. More details can be found at:
https://lists.gnu.org/r/bug-gzip/2022-04/msg00011.html
DISCLOSURE TIMELINE
  • 2022-03-23 - Vulnerability reported to vendor
  • 2022-10-21 - Coordinated public release of advisory
CREDIT cleemy desu wayo
BACK TO ADVISORIES