Advisory Details

November 15th, 2022

Parse Server transformUpdate Prototype Pollution Remote Code Execution Vulnerability

ZDI-22-1590
ZDI-CAN-18358

CVE ID CVE-2022-39396
CVSS SCORE 9.8, (AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Parse
AFFECTED PRODUCTS Server
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Parse Server. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the transformUpdate function. The issue results from the lack of control over modifications to attributes of object prototypes. An attacker can leverage this vulnerability to execute code in the context of the service account.

ADDITIONAL DETAILS Parse has issued an update to correct this vulnerability. More details can be found at:
https://github.com/parse-community/parse-server/security/advisories/GHSA-prm5-8g2m-24gg
DISCLOSURE TIMELINE
  • 2022-09-20 - Vulnerability reported to vendor
  • 2022-11-15 - Coordinated public release of advisory
CREDIT Mikhail Shcherbakov (KTH), Cristian-Alexandru Staicu (CISPA) and Musard Balliu (KTH)
BACK TO ADVISORIES