Advisory Details

November 21st, 2022

ManageEngine ServiceDesk Plus invokeDataUploadTool Command Injection Remote Code Execution Vulnerability

ZDI-22-1611
ZDI-CAN-18260

CVE ID CVE-2022-40770
CVSS SCORE 7.2, (AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS ManageEngine
AFFECTED PRODUCTS ServiceDesk Plus
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of ManageEngine ServiceDesk Plus. Authentication is required to exploit this vulnerability.

The specific flaw exists within the invokeDataUploadTool function. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of SYSTEM.

ADDITIONAL DETAILS ManageEngine has issued an update to correct this vulnerability. More details can be found at:
https://www.manageengine.com/products/service-desk/CVE-2022-40770.html
DISCLOSURE TIMELINE
  • 2022-08-10 - Vulnerability reported to vendor
  • 2022-11-21 - Coordinated public release of advisory
CREDIT Piotr Bazydlo (@chudypb) of Trend Micro Zero Day Initiative
BACK TO ADVISORIES