Advisory Details

November 22nd, 2022

Microsoft Exchange ScriptingAgentConfiguration Exposed Dangerous Function Information Disclosure Vulnerability

ZDI-22-1633
ZDI-CAN-18941

CVE ID CVE-2022-41082
CVSS SCORE 4.3, (AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
AFFECTED VENDORS Microsoft
AFFECTED PRODUCTS Exchange
VULNERABILITY DETAILS

This vulnerability allows remote attackers to disclose sensitive information on affected installations of Microsoft Exchange. Authentication is required to exploit this vulnerability.

The specific flaw exists within the ScriptingAgentConfiguration class. The issue results from the exposure of a dangerous function. An attacker can leverage this vulnerability to disclose information in the context of SYSTEM.

ADDITIONAL DETAILS Microsoft has issued an update to correct this vulnerability. More details can be found at:
https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-41082
DISCLOSURE TIMELINE
  • 2022-10-04 - Vulnerability reported to vendor
  • 2022-11-22 - Coordinated public release of advisory
CREDIT Piotr Bazydlo (@chudypb) of Trend Micro Zero Day Initiative
BACK TO ADVISORIES