Advisory Details

November 23rd, 2022

SolarWinds Network Performance Monitor DeserializeFromStrippedXml Deserialization of Untrusted Data Remote Code Execution Vulnerability

ZDI-22-1664
ZDI-CAN-17718

CVE ID CVE-2022-36964
CVSS SCORE 8.8, (AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS SolarWinds
AFFECTED PRODUCTS Network Performance Monitor
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of SolarWinds Network Performance Monitor. Authentication is required to exploit this vulnerability.

The specific flaw exists within the DeserializeFromStrippedXml function. The issue results from the lack of proper validation of user-supplied data, which can result in deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of SYSTEM.

ADDITIONAL DETAILS SolarWinds has issued an update to correct this vulnerability. More details can be found at:
https://www.solarwinds.com/trust-center/security-advisories/cve-2022-36964
DISCLOSURE TIMELINE
  • 2022-06-24 - Vulnerability reported to vendor
  • 2022-11-23 - Coordinated public release of advisory
CREDIT Piotr Bazydlo (@chudypb) of Trend Micro Zero Day Initiative
BACK TO ADVISORIES