Advisory Details

February 16th, 2022

Apple macOS ImageIO PICT File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability

ZDI-22-353
ZDI-CAN-13806

CVE ID CVE-2021-30785
CVSS SCORE 7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Apple
AFFECTED PRODUCTS macOS
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Apple macOS. Interaction with the ImageIO library is required to exploit this vulnerability but attack vectors may vary depending on the implementation.

The specific flaw exists within the ImageIO framework. Crafted data in a PICT file can trigger an overflow of a heap-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS Apple has issued an update to correct this vulnerability. More details can be found at:
https://support.apple.com/HT212602
DISCLOSURE TIMELINE
  • 2021-04-30 - Vulnerability reported to vendor
  • 2022-02-16 - Coordinated public release of advisory
CREDIT Mickey Jin (@patch1t) of Trend Micro
BACK TO ADVISORIES