Advisory Details

February 18th, 2022

Lexmark MC3224i PostScript Out-Of-Bounds Write Remote Code Execution Vulnerability

ZDI-22-382
ZDI-CAN-15982

CVE ID CVE-2021-44738
CVSS SCORE 8.8, (AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Lexmark
AFFECTED PRODUCTS MC3224i
VULNERABILITY DETAILS

This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of Lexmark MC3224i printers. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the parsing of PostScript data. Crafted PostScript data can trigger a write past the end of an allocated buffer. An attacker can leverage this vulnerability to execute code in the context of root.

ADDITIONAL DETAILS Lexmark has issued an update to correct this vulnerability. More details can be found at:
https://publications.lexmark.com/publications/security-alerts/CVE-2021-44738.pdf
DISCLOSURE TIMELINE
  • 2022-01-28 - Vulnerability reported to vendor
  • 2022-02-18 - Coordinated public release of advisory
CREDIT Christopher Anastasio @mufinnnnnnn and Justin Taft @JustTaft
BACK TO ADVISORIES