Advisory Details

February 22nd, 2022

TP-Link TL-WR940N httpd Improper Access Control Information Disclosure Vulnerability

ZDI-22-405
ZDI-CAN-13911

CVE ID CVE-2022-24972
CVSS SCORE 6.5, (AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N)
AFFECTED VENDORS TP-Link
AFFECTED PRODUCTS TL-WR940N
VULNERABILITY DETAILS

This vulnerability allows network-adjacent attackers to disclose sensitive information on affected installations of TP-Link TL-WR940N routers. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the httpd service, which listens on TCP port 80 by default. The issue results from the lack of proper access control. An attacker can leverage this vulnerability to disclose stored credentials, leading to further compromise.

ADDITIONAL DETAILS

Fixed in firmware 211111


DISCLOSURE TIMELINE
  • 2021-10-21 - Vulnerability reported to vendor
  • 2022-02-22 - Coordinated public release of advisory
CREDIT Vadym Kolisnichenko
BACK TO ADVISORIES