Advisory Details

March 29th, 2022

(Pwn2Own) Netgear R6700v3 NetUSB Integer Overflow Remote Code Execution Vulnerability

ZDI-22-544
ZDI-CAN-15806

CVE ID CVE-2022-27641
CVSS SCORE 8.8, (AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS NETGEAR
AFFECTED PRODUCTS R6700v3
VULNERABILITY DETAILS

This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR R6700v3 routers. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the NetUSB module. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code in the context of root.

ADDITIONAL DETAILS NETGEAR has issued an update to correct this vulnerability. More details can be found at:
https://kb.netgear.com/000064437/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Multiple-Products-PSV-2021-0278
DISCLOSURE TIMELINE
  • 2021-12-01 - Vulnerability reported to vendor
  • 2022-03-29 - Coordinated public release of advisory
CREDIT trichimtrich and nyancat0131
BACK TO ADVISORIES