Advisory Details

May 10th, 2022

(Pwn2Own) NETGEAR R6700v3 Vulnerable Third-Party Component Remote Code Execution Vulnerability

ZDI-22-758
ZDI-CAN-15803

CVE ID
CVSS SCORE 8.8, (AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
AFFECTED VENDORS NETGEAR
AFFECTED PRODUCTS Multiple Routers
VULNERABILITY DETAILS

This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR R6700v3 routers. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the Netatalk library that is installed on NETGEAR R6700v3 routers. The issue results from the use of an outdated version of Netatalk containing known vulnerabilities. An attacker can leverage this vulnerability to execute code in the context of root.

ADDITIONAL DETAILS NETGEAR has issued an update to correct this vulnerability. More details can be found at:
https://kb.netgear.com/000064719/Security-Advisory-for-Multiple-Vulnerabilities-on-Multiple-Products-PSV-2021-0321
DISCLOSURE TIMELINE
  • 2021-12-01 - Vulnerability reported to vendor
  • 2022-05-10 - Coordinated public release of advisory
  • 2022-05-11 - Advisory Updated
CREDIT Torchy's Corporate Ethical Hacking Team at crixer(@pwning_me), chillbro4201(@chillbro4201)
BACK TO ADVISORIES